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СТВОРЕННЯ НЕЧІТКОЇ МОДЕЛІ ТЕХНОЛОГІЧНОГО ОБ'ЄКТА

ЗАСОБАМИ МАТЕМАТИЧНОГО ПРОЦЕСОРА MATLAB

Мета роботи  ознайомитись із способом створенням математичних

моделей об’єкта управління на базі нечіткої логіки засобами MATLAB,

навчитися досліджувати такі моделі.

Стислі теоретичні відомості

Нечітка логіка (Fuzzy Logic) – це надмножина класичної булевої

логіки. Вона розширює можливості останньої, дозволяючи застосовувати

концепцію невизначеності в логічних висновках. Апарат нечіткої логіки теж

строгий і точний, як і класичний, але разом із протилежними значеннями

«хибність» та «істина» він дозволяє використовувати значення, що

знаходяться між ними.

Нечітка множина (Fuzzy Set) є сукупністю елементів довільної

природи, щодо яких не можна з повною визначеністю стверджувати, чи

належить той або інший елемент сукупності певній множині чи ні. Іншими

словами, не можна чітко визначити, що даний вислів є «хибністю» або

«істиною» («чорним» або «білим»), оскільки множина «чорно-біле» містить

усі відтінки від чорного до білого.

Функція належності (Membership Functions) є апаратом для

символьного (математичного) опису нечіткої множини. Вона показує цей

перехід від «істини» до «хибності». Жодних обмежень на вибір конкретної

функції належності немає.

Проте, на практиці зручно використовувати ті з них, які допускають

аналітичне подання у вигляді простої математичної функції. Необхідність

типізації окремих функцій належності обумовлена реалізацією відповідних

функцій в інструментальних засобах, наприклад, у MATLAB.
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Для реалізації процесу нечіткого моделювання в середовищі MATLAB 

призначений спеціальний пакет розширення Fuzzy Logic Toolbox. У рамках 

цього пакету користувач може виконувати необхідні дії по розробці і 

використанню нечітких моделей. 

Застосуємо метод нечіткого моделювання для процесів сушіння та 

грануляції мінеральних добрив, які відбуваються в апараті «барабанний 

гранулятор  сушарка» (БГС). Для створення нечіткої моделі ознайомимося з 

технологічними особливостями об’єкта керування. 

 Упарена пульпа збирається у збірнику з мішалкою і обігрівом, звідки 

прямує в апарат БГС на грануляцію і сушіння.  

 Пульпа напилюється пневматичною форсункою на завісу сухого матеріалу 

(так званий ретур). Гранули укрупнюються, обкочуються і висушуються. 

Отримані гранули добре обкатані і містять 0,5-1% вологи. Сушіння 

здійснюється топковими газами, які подаються прямотечією до 

диспергованих часток при температурі на вході  

450 – 500 °С, температура газів на виході 90-100 °С.  

 Висушений продукт розділяють на три фракції: велику (  > 3,2 мм), 

товарну і дрібну ( <1 мм). Гранули великої фракції подрібнюються в 

лотковій дробарці, подрібнений матеріал іде знову на розсіювання разом з 

основним потоком матеріалу. Гранули +3,2 мм з верхнього сита 

подаються на валкову дробарку, а потім знову на розсівання.  

 Готовий продукт з нижнього сита йде на охолоджування, а потім на склад: 

фракції діаметром меншим за 1 мм повертаються в БГС як ретур.  

Задача полягає в тому, щоб розробити систему управління процесом 

гранулоутворення, яка б ґрунтувалася на нечіткому моделюванні, 

враховуючи досвід спеціалістів з керування БГС. 
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На перебіг процесів сушіння та гранулоутворення безпосередньо 

впливає щільність завіси ретуру перед форсункою, а також концентрація 

дрібної фракції на виході апарату БГС, вплив якої буде відчутно через 

певний час. Кваліфіковані експерти співставляють ці дві змінні для 

нанесення керувального впливу.  

Керувальною змінною у системі керування визначено тиск повітря у 

пневматичній форсунці.  

З огляду на це факторами моделі визначимо 2 нечіткі лінгвістичні 

змінні: «концентрація дрібної фракції на виході апарату» і «завіса», а як 

вихідну змінну — нечітку лінгвістичну змінну «тиск повітря  

пневмофорсунки» (далі «тиск»). 

За Терм - множину першої лінгвістичної змінної «концентрація 

дрібної фракції» візьмемо множину Т1={«Занадто мало», «Мало», 

«Нормально», «Багато», «Занадто багато»}, а за терм - множину другої 

лінгвістичної змінної «завіса» використаємо множину Т2={«рідка», 

«нормальна», «щільна»}. За терм - множину вихідної лінгвістичної змінної 

«тиск» візьмемо множину Т3={«Дуже малий», «Малий», «Зменшений», 

«Нормальний», «Збільшений», «Великий», «Дуже великий»}. При цьому терм 

першої вхідної змінної (концентрація дрібної фракції) оцінюватимемо по 20 

- процентній шкалі, при якій цифрі 0 відповідає якнайменша концентрація 

дрібної фракції на виході БГС, а цифрі 20  найбільша концентрація дрібної 

фракції на виході БГС. Терм другої вхідної змінної («завіса») оцінюватимемо 

за 10 - бальною шкалою, при якій цифрі 0 відповідає якнайменша щільність 

завіси в БГС, а цифрі 10 — найбільша. Що стосується терма вихідної змінної 

«тиск», то її шкала буде проградуйована в МПа від 0,3 до 0,6 МПа в порядку 

зростання.  
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Порядок виконання роботи

Процес розробки системи і моделі нечіткого висновку в

інтерактивному режимі для розглянутого вище прикладу «Барабанний

гранулятор – сушарка» полягає у виконанні наступної послідовності дій.

1. Викликати редактор системи нечіткого висновку FIS, для чого у

вікні команд набрати ім'я відповідної функції fuzzy. Після виконання цієї

команди на екрані з'явиться графічний інтерфейс редактора FIS з ім'ям

системи нечіткого висновку Untitled і типом системи нечіткого висновку

(Мамдані), запропонованим за умовчанням.

2. Оскільки в прикладі 1 розглянуто систему нечіткого висновку з

двома входами, то необхідно додати в систему FIS, що розробляється, ще

одну вхідну змінну. Для цього слід виконати команду меню Edit>Add

Variable... >Input. У результаті виконання цієї команди на діаграмі системи

нечіткого висновку з'явиться новий жовтий прямокутник з ім'ям другої

вхідної змінної: input2. (див рис.    )

        . Вид редактора FIS після додавання другої вхідної змінної
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3. Змінимо імена вхідних і вихідних змінних, запропонованих

системою MATLAB за умовчанням. Для цього необхідно виділити

прямокутник з ім'ям відповідної змінної, виконавши клацання на його

зображенні на діаграмі (сторони виділеного прямокутника мають червоний

колір). Після цього слід набрати нове ім'я змінної в полі введення Name у

правій частині редактора FIS. Результат надання нових імен змінним системи

нечіткого висновку зображений на рис.     

         Вид редактора FIS після надання нових імен змінним

Змінимо ім'я системи нечіткого висновку (Untitled), запропоноване за

умовчанням. Для цього збережемо створену структуру FIS в зовнішньому

файлі з ім'ям mytip.fis, виконавши команду меню File>Export>To Disk.... При

цьому буде викликано стандартне діалогове вікно збереження файлу, в якому

користувачу пропонують ввести ім'я відповідного файлу (розширення файлу

приписується автоматично).
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Залишимо без зміни запропоновані системою MATLAB за умовчанням:

метод нечіткого логічного І (And method) — значення «min», метод нечіткого

логічного АБО (Or method) — значення «max», метод імплікації (Implication)

 значення «min», метод агрегації (Aggregation)  значення «max» і метод

дефаззификации (Defuzzification)  значення «сеntroid». Очевидно, що ці

значення можуть бути змінені користувачем.

4. Тепер необхідно визначити терми і їх функції належності для

вхідних і вихідних змінних нашої системи нечіткого висновку. Для цієї мети

слід скористатися редактором функцій належності, який може бути

викликаний одним з наступних способів:

 подвійним клацанням ЛКМ на значку прямокутника з ім'ям відповідної

змінної;

 командою меню Edit>Membership Functions... (заздалегідь повинен бути

виділений прямокутник з ім'ям відповідної змінної).

Після виклику редактора функцій належності кожної із змінних за

умовчанням пропонується 3 терми з трикутними функції належності

          

Спочатку змінимо діапазон значень вхідних змінних, для чого в полях

введення Range і Display Range змінимо верхнє значення з 1 на 20

(відсотків). Аналогічно виконуються зміни відповідних діапазонів для

вхідної змінної «завіса» [0  10] і для вихідної змінної «тиск пневмофорсунки»

[0.3  0.6]. Зміни підтверджуються натисканням на клавішу  Enter  на

клавіатурі.

Оскільки для вибраної задачі необхідно 5 термів, а система MATLAB

пропонує за умовчанням тільки 3. Командою меню Edit>Remove All MFs

видаляємо запропоновані терми. Командою меню Edit>Add MFs…

створюємо 5 нових термів.            
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         Вигляд редактора функцій належності після його виклику, з функціями

належності для термів змінної «Концентрація дрібної фракції», запропонованих системою

MATLAB за умовчанням

Рис.4.4. Вигляд вікна створення необхідної кількості термів

Далі змінимо назви термів першої вхідної змінної «Концентрація

дрібної фракції», створених нами (mf1, mf2, mf3, mf4, mf5) на «Занадто

мало», «Мало», «Нормально», «Багато», «Занадто багато»  відповідно.

Після чого змінимо тип крайніх функцій належності, запропонованих за

умовчанням, на трапецієвидні функції (trapmf), вибравши відповідний

пункт в полі Type.
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Параметри функцій задамо таким чином: для терма  «Занадто

мало» задамо параметри [0 0 2 6], для терма «Мало» – [2 6 10], для терма

«Нормально» – [6 10 14], для терма «Багато» – [10 14 18], для терма

«Занадто багато» – [14 18 20 20]. Вигляд редактора функцій належності

після внесених змін зображений на рис.4.5.

         Вигляд редактора функцій належності після зміни назви термів і типу функцій

належності для першої вхідної змінної «Концентрація дрібної фракції»

Аналогічним чином змінимо назви термів другої вхідної змінної

«Завіса». Після чого змінимо, запропонований за умовчанням, тип функцій

належності на функції типу Гауса (gaussmf), вибравши відповідний пункт в

полі Type. Параметри функцій належності залишимо без змін. За терм-

множину другої лінгвістичної змінної «Завіса» використано «Рідка»,

«Нормальна», «Щільна». Вигляд редактора функцій належності після

внесених змін зображений на рис.     
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         Вигляд редактора функцій належності після зміни назви термів і типу їх функцій

належності для другої вхідної змінної «Завіса»

Нарешті, змінимо назви термів і параметри функцій належності для

вихідної змінної «Тиск пневмофорсунки» . Нам необхідні 7 термів, а

система MATLAB пропонує за умовчанням тільки 3. Командою меню

Edit>Remove All MFs  видаляємо запропоновані терми. Командою меню

Edit>Add MFs.  створюємо 7 нових термів. Далі змінимо назви термів

вихідної змінної «Тиск пневмофорсунки», створених нами (mf1, mf2, mf3,

mf4, mf5, mf6, mf7) на  «Дуже малий», «Малий», «Зменшений»,

«Нормальний», «Збільшений», «Великий», «Дуже великий»  відповідно.

Після чого змінимо тип крайніх функцій належності, запропонованих за

умовчанням, на трапецієвидні функції (trapmf), вибравши відповідний

пункт в полі Type. Параметри функцій задамо таким чином: для терма

«Дуже малий» задамо параметри [0.3 0.3 0.3283 0.3667], для терма

«Малий» – [0.3283 0.3667 0.4083], для терма «Зменшений» –  [0.3667

0.4083 0.45], для терма «Нормальний» –  [0.4083 0.45 0.4917],
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для терма «Збільшений» –  [0.45 0.4917 0.5333], для терма «Великий» –

[0.4917 0.5333 0.5716], для терма «Дуже великий» –  [0.5333 0.5716 0.6

0.6]. Вид редактора функцій належності після внесених змін зображений

на рис.    .

          Вигляд редактора функцій належності після зміни назви термів і типу функцій

належності для другої вихідної змінної «Тиск пневмофорсунки»

Порядок виконання роботи

1. Створити модель процесу гранулоутворення мінеральних добрив у

барабанному грануляторі - сушарці за методикою, описаною в роботі.

2. Розробити математичну модель на базі нечіткого моделювання для

власного технологічного об’єкта керування, узгодженого з викладачем.

3. Дослідити типи функцій належності, які надає пакет, і способи їх

математичного подання.
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Вміст звіту 

Структурно – параметрична схема для власного об’єкта керування. 

Опис лінгвістичних змінних, які використані у моделі процесу, вікна 

редактора MATLAB із зображеннями та характеристиками функцій 

належності. 

Контрольні запитання 

1. Як описати лінгвістичну змінну? 

2. Які існують види функцій належності? 

3. Як додати вхідну змінну в редакторі пакету Fuzzy Logic? 

4. Як надати лінгвістичній змінній певне ім’я? 

5. Як задати терми і функції належності лінгвістичної змінної? 

6. Як змінити кількість термів? 

7. Як змінити тип функції належності? 

8. Як задати потрібний діапазон значень лінгвістичної змінної? 


